All Collections
General
MYOB
-28 : Item not sold
-28 : Item not sold

How to resolve Item not sold error

Updated over a week ago

Description

This error simply means that one of the item in this sale does not setup as 'I Sell This Item' in MYOB. Refer to image below:

Detail Steps

Cause 1:

  1. Please go to MYOB and check item/items to make sure 'I Sell This Item' is ticked.

  2. Go back to WMS and perform Fast replication.

    Also if one of the time is inactive in sale order, you will get this error during replication as MYOB not able to recognize this as an ITEM hence this error is shown. Inactive item will come with hash ## in item number. User needs to release the ALERT, right-click > undo shipped > right-click > release order, then remove the inactive item from sale order and ship back.

Cause 2:

Item \C is uppercase. This error could also be due to \c comment line setup \C uppercase where it should be \c.

Related Information

None

Did this answer your question?